Resolving "JInitiator version too low" Errors in EBS Environments


Oracle JInitiator 1.3 was desupported for E-Business Suite environments at the end of July 2009.  JInitiator 1.1.8 was desupported at the end of December 2008. E-Business Suite users should have switched from Oracle JInitiator to the native Java JRE plug-in at that time.
Some users might be seeing confusing error messages like this:
FRM-92095: Oracle Jlnitiator version too low. Please install version 1.1.8.2 or higher.
FRM-92095: Oracle Jlnitiator version too low. Please install version 1.1.8.2 or higher.
Details:
Java Exception: oracle.forms.engine.RunformException: FRM-92095: oracle Jlnitiator version too low. Please install version 1.1.8.2 or higher.

at oraclr.forms.net.HTTPConnection.<init>(Unknown Source)
at oraclr.forms.engine.FormsDispatcher.initConnection(Unknown Source)
at oraclr.forms.engine.FormsDispatcher.init(Unknown Source)
at oraclr.forms.Runform.initConnection(Unknown Source)
at oraclr.forms.Runform.startRunForm(Unknown Source)
at oraclr.forms.Main.createRunform(Unknown Source)
at oraclr.forms.Main.start(Unknown Source)
at com.sun.deploy.uitoolkit.impl.awt.AWTAppletAdapter.start(Unknown Source)
at sun.plugin2.applet.plugin2Manager$AppletExecutuonRunnable.run(Unknown Source)
at java.lang.Thread.run(Threat.java.722)
What's causing this error?
This error message may occur if you try and launch an E-Business Suite form using the JRE 7 client plug-in without applying the prerequisite Forms patch needed to enable JRE 7 compatibility.
What's needed to enable EBS environments for JRE 7?
EBS customers should ensure that they are running the latest JRE 7 plug-in, at minimum, on Windows desktop clients.  If you've reached this article via a search engine, please check our Certifications summary page for the latest certified JRE 7 release.

Of the compatibility issues identified with JRE 7, the most critical is an issue that prevents E-Business Suite Forms-based products from launching on Windows desktops that are running JRE 7. 
Customers can prevent this issue -- and all other JRE 7 compatibility issues -- by ensuring that they have applied the latest certified patches documented for JRE 7 configurations to their EBS application tier servers.  These are summarized here for convenience. If the requirements change over time, please check the Notes for the authoritative list of patches: 
  1. Apply Forms patch 14615390 to EBS 11i environments (Note 125767.1)
  2. Apply Forms patch 14614795 to EBS 12.0 and 12.1 environments (Note 437878.1)
These patches are compatible with JRE 6 and 7, production ready, and fully-tested with the E-Business Suite.  These patches may be applied immediately to all E-Business Suite environments. All other Forms prerequisites documented in the Notes above should also be applied. 
Where are the official patch requirements documented?
All patches required for ensuring full compatibility of the E-Business Suite with JRE 7 are documented in these Notes:

For EBS 11i: 
For EBS 12

2 comments:

  1. Regards
    Sridevi Koduru (Senior Oracle Apps Trainer Oracleappstechnical.com)
    LinkedIn profile - https://in.linkedin.com/in/sridevi-koduru-9b876a8b
    Please Contact for One to One Online Training on Oracle Apps Technical, Financials, SCM, SQL, PL/SQL, D2K at training@oracleappstechnical.com | +91 - 9581017828.

    ReplyDelete
  2. I have read your blog its very attractive and impressive. I like it your blog.

    Java Online Training Java EE Online Training Java EE Online Training Java 8 online training Java 8 online training

    Java Online Training from India Java Online Training from India Core Java Training Online Core Java Training Online Java Training InstitutesJava Training Institutes

    ReplyDelete

Note: Only a member of this blog may post a comment.